Select the search type
  • Site
  • Web
You are here:  Support/Forums

Bring2mind Forums

WebDAV with Windows 7, Vista, and XP
Last Post 06/14/2010 3:07 PM by Siri. 1 Replies.
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Cape Fear Web Masters
New Member
New Member

06/08/2010 8:52 PM

I’ve spent the last 3 months with DMX on several different DMX installations and I wanted to take a minute to share my experience regarding WebDAV and the Windows Clients. This is by no means a formal “this works and doesn’t work” post… it’s a “Hey this is what I’ve experienced so far and would love to see if you saw something different” type post  

Windows XP – works with WebDav perfectly

Windows Vista – does NOT work with DMX WebDAV natively. You need to install the following patches. In general WebDAV and Vista works but my experience over the past few months (and 480 desktops) is that it’s cranky.

1. KB 907306 NOTE this is not included in Vista SP2 – but is in Office 2007 updates

2. KB 942392  corrected with Vista SP1

3. KB 941298  corrected with Vista SP1

4. KB 941890 corrected with Vista SP1

5. In addition to these updates you need to review if you are using WebDAV over HTTP and not HTTPS

Windows 7 – WebDAV appears to only work for Sharepoint. It does not work with any 3rd party WebDaV server that I have tested so far (including DMX). There are no current KB articles on it. There are hundreds and hundreds of complaints about it (do a quick search on google). At this time the only way I’ve been successful with Windows 7 and DMX is using a 3rd party WebDAV client like webdrive ( . I’m not saying that Windows 7 won’t work… I’m saying that I haven’t been able to get it to work reliably. This *may* be corrected with the upcoming SP for windows 7.

New Member
New Member

06/14/2010 3:07 PM


Just thought I'd share my experiances with WebDav and dotNetNuke performance settings in case anyone else come across same problems as I.

<!--[if !mso]> <!--[if gte mso 9]> Normal 0 21 false false false NO-BOK X-NONE X-NONE MicrosoftInternetExplorer4 <!-- /* Font Definitions */ @font-face {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0; mso-font-charset:2; mso-generic-font-family:auto; mso-font-pitch:variable; mso-font-signature:0 268435456 0 0 -2147483648 0;} @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-520092929 1073786111 9 0 415 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0cm; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; font-size:10.0pt; mso-ansi-font-size:10.0pt; mso-bidi-font-size:10.0pt;} @page WordSection1 {size:612.0pt 792.0pt; margin:70.85pt 70.85pt 70.85pt 70.85pt; mso-header-margin:35.4pt; mso-footer-margin:35.4pt; mso-paper-source:0;} div.WordSection1 {page:WordSection1;} --> <!--[if gte mso 10]> The settings I am talking about is under Host > Host settings > Advanced Settings > Performance Settings.

After I got WebDav to work I later changed caching and compression settings to have better performance of the sites. DNN can be quite slow and caching helped a lot with that but then a week later I discovered I could not edit documents in Word any more.  They all opened as read only with no content and using Fiddler I found there were no lock-requests.

After much head scratching a bit of experimenting I set Compression Settings to No Compression and and Caching settings to No Caching. I then clicked clear cache and that got WebDav working again.


<!--[if gte vml 1]>

You are not authorized to post a reply.